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TimeMachineで、「バックアップフォルダの作成中にエラーが起きました」となり、バックアップに失敗する

2011年07月11日

問題

MacOS X のバックアップ機能「TimeMachine」において、数回目のバックアップから、次のようなエラーメッセージが表示され、バックアップに失敗することがありました。

バックアップを完了できませんでした。

バックアップの作成を完了できません。バックアップフォルダの作成中にエラーが起きました。

また、コンソールのエラーログには、以下のようなメッセージが記録されます。
Error: (22) setxattr for key:com.apple.backupd.ModelID path:/Volumes/(バックアップ先ドライブ名)/Backups.backupdb/(コンピュータ名) size:8
Error: (-50) Creating directory 2011-07-11-223534.inProgress Failed to make snapshot container.
com.apple.backupd[18822] Error: (22) setxattr for key:com.apple.backupd.ModelID path:/Volumes/(バックアップ先ドライブ名)/Backups.backupdb/(コンピュータ名) size:8
com.apple.backupd[18822] Backup failed with error: 2

原因

バックアップ先に指定したドライブに、Spotlightのインデックス作成プロセスがアクセスしていて、一部のファイルにTimeMachineがアクセスできなかったのが原因のようです。

解決策

支障がなければ、バックアップ先ドライブを、Spotlightから除外してください。

  1. アップルメニュー(C) → システム環境設定(C) → Spotlight(C)
  2. プライバシー(C)
  3. 「+」(C) → バックアップ先ドライブを選択 → 「選択」(C)
  4. システム環境設定を閉じる

※除外設定時、「プライバシーリストエラー」が表示されるときは、Spotlightインデックスの作成中の可能性があります。そのドライブを強制的にマウント解除、再びマウントし、すみやかに設定しなおしてください。

補足

発生環境

システム
MacOS X 10.6.8

投稿者 とみっぺ : 2011年07月11日 | コメント (0) | トラックバック

十分な空きメモリがあるにもかかわらずメモリ不足の状態になる

2005年08月20日

問題

Windows NT、2000、XP において、多くの空きメモリーがあるにもかかわらず、ソフトウェアを多数起動している場合などに、次の現象が発生し、メモリ不足のような状態に陥ることがあります。

なお、以下で言う「オブジェクト」とは、デスクトップ上に表示されるウィンドウ・ボタン・メニュー・アイコンなどのあらゆる要素を指します。

しかしながら、起動中のプログラムを終了すると、残りのプログラムが正常に動作することもあります。

原因

Windows システムの「デスクトップアプリケーションのヒープ」が不足しているためです。これはWindows システムがあらゆる(ユーザーモードの)プログラムのオブジェクトを描画する際に使用するために割り当てた特別なメモリー空間で、その容量はシステムの設定により固定されています。

解決策

このトラブルが発生した際、尋常ではない数のプログラムを起動していたなど、普段では考えられないケースである場合は、問題ありません。普段からあまりに多くのプログラムを起動しないようにしてください。

しかし、普段の作業中にこのエラーが頻繁に発生するなど、明らかにヒープの容量が不足している場合は、レジストリの値を変更し、ヒープの容量を増やしてください。

その方法は、以下の通りです。

  1. レジストリエディタを起動する
    • スタート(C) → ファイル名を指定して実行(C) → 「regedit」と入力 → OK(C)
  2. 次のレジストリキーを開く
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubSystems
  3. 「Windows」の値のうち、以下の赤字の部分の値を変更する
    %SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows SharedSection=1024,3072,512 Windows=On SubSystemType=Windows ServerDll=basesrv,1 ServerDll=winsrv:GdiServerDllInitialization,4 ServerDll=winsrv:UserServerDllInitialization,3 ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off MaxRequestThreads=16
  4. レジストリエディタを終了し、再起動する

参考記事・関連リンク

備考

投稿者 とみっぺ : 2005年08月20日 | コメント (0) | トラックバック

エクスプローラのフォルダペインにおいて、アイコンが表示されない

2005年02月06日

問題

エクスプローラ(フォルダをダブルクリックした際にその内容が表示されるアプリケーション)ウィンドウを開くと、フォルダペインにアイコンが表示されず、文字のみのフォルダリストが表示される場合があります。

この症状は、通常のエクスプローラウィンドウのみならず、次に示すウィンドウなどでも起こります。

ファイル・フォルダ操作において支障はありませんが、フォルダの種類を判別しにくいと感じたり、何となく腑に落ちない気持ちになったりするかもしれません。

原因

そのシステムにおいてCドライブ(パーティション)が存在しない状態にあることが原因です。

この状態は、次に示す条件が重なった場合に起こり得ます。

解決策

Cドライブが存在する状態にして下さい。

たちまちには、リムーバブルディスクをコンピュータに装着すればかまいませんが、ハードディスクやCDなど通常取り外さないドライブ(またはそのパーティション)を割り当てることが確実な解決となります。

今回の発生条件

システム
Windows XP Professional (SP1)

備考

原因と症状の因果関係は不明です。Windows のバグだと思われます。

投稿者 とみっぺ : 2005年02月06日 | コメント (0) | トラックバック

特定のユーザーアカウントが削除できない

2004年12月08日

問題

Windows XP / 2000 で、コントロールパネルの[ユーザーアカウント]から、特定のユーザーアカウントが削除できない場合があります。

原因

Windows XP / 2000 では、次のユーザーアカウントはコントロールパネルの[ユーザーアカウント]経由では削除できないようになっています。

解決法

MMC[コンピュータの管理]から削除できます。

  1. [スタート]C (→ 設定) → [コントロールパネル]C
  2. ([クラシック表示にする]C→) [管理ツール]WC
  3. [コンピュータの管理]C
  4. [ローカルユーザーとグループ]WC → [ユーザー]C
  5. 削除したいアカウントの項目を 右C し、[削除]C してください。
  6. 削除処理終了後は、適宜ウィンドウを閉じて下さい。

投稿者 とみっぺ : 2004年12月08日 | コメント (0) | トラックバック

ウィンドウが画面の外へはみ出し、移動、サイズの変更ができない

2004年11月26日

問題

ウィンドウが画面の外にはみ出し、位置によっては移動、サイズの変更がしにくい場合があります。

原因

Internet Explorerなどで、意図せずサイズが大きく変更不可の新規ポップアップウィンドウが出たときなどは、通常のマウス操作では移動やサイズ変更が難しい場合があります。

とみっぺがお受けした今回のご相談では、タブブラウザを実行中、意図せず広告のポップアップ「タブ」が意図せず出て、タブブラウザのウィンドウそのもののサイズが自動的に大きくなり、元に戻せなくなったということでした。

解決法

このような場合に強制的にウィンドウを制御可能な状態にする便利な方法として、タスクバーからのウィンドウの整列があります。

タスクバー([スタート]ボタンがあるバー)の何もないところを右C→[重ねて表示]C を行って下さい。すると、デスクトップに現存するすべてのウィンドウが強制的に整列され、サイズと位置が変わります。

対象

投稿者 とみっぺ : 2004年11月26日 | コメント (0) | トラックバック

操作中突然画面が止まり、応答しない

2004年11月25日

問題

コンピュータを操作中、画面全体または特定のソフトウェアの動作が止まり(フリーズ)、マウスやキーボードなどの入力を受け付けず、応答しなくなることがあります。

原因

原因は様々ですが、次のようなことが考えられます。

解決法

Windows XP・2000の場合

  1. まず、キーボードの[Alt]を押したまま、[Tab]を押して下さい。
  2. 画面が全く変わらない場合は、完全にコンピュータがフリーズしていますので、本体にある電源ボタンを5秒程度長押しして下さい。
  3. 画面の中央に小さいダイアログ(タスクの切り替えダイアログ)が出る場合は、コンピュータは応答する可能性があります。キーボードの[Ctrl]+[Shift]+[Esc]を同時に押して下さい。[タスクマネージャ]が起動します。
  4. [アプリケーション]タブの中に、現在実行中のアプリケーション(ソフトウェア)が列挙されています。この中で、項目名の末尾に「(応答なし)」とあるものがあれば、今回のフリーズの原因である可能性があります。[その項目]C→[タスクの終了]Cを行うと、強制終了することができます。
  5. それで解決できない場合は、メニューの[シャットダウン]C→[再起動]C を行って下さい。すると、強制的に再起動します。

Windows Me・98・95の場合

  1. まず、キーボードの[Alt]を押したまま、[Tab]を押して下さい。
  2. 画面が全く変わらない場合は、完全にコンピュータがフリーズしていますので、本体にある電源ボタンを5秒程度長押しして下さい。
  3. 画面の中央に小さいダイアログ(タスクの切り替えダイアログ)が出る場合は、コンピュータは応答する可能性があります。キーボードの[Ctrl]+[Alt]+[Delete]を同時に押して下さい。[アプリケーションの強制終了]ダイアログが出ます。
  4. すると、現在実行中のアプリケーション(ソフトウェア)が表示されますが、たいてい個別に強制終了することはできません。ここで、もう一度キーボードの[Ctrl]+[Alt]+[Delete]を同時に押して下さい。すると、強制的に再起動が行われます。
  5. エラーメッセージが出るなど、それでも再起動しない場合は、本体の電源ボタンを5秒程度長押しして下さい。

備考

特定のソフトウェアを強制終了したり、強制再起動をした場合は、それまで作業していたデータはすべて消去されます。

参考記事・関連リンク

投稿者 とみっぺ : 2004年11月25日 | コメント (0) | トラックバック